Saving and Managing Graphs

IMPORTANT NOTE: Before saving graphs or accessing your saved graphs in the Desmos Graphing Calculator make sure you have created a free teacher or student account, and that you are signed in.

Saving Graphs | Managing Your Saved Graph Collection| Sharing Your Saved Graphs| Recovering Unsaved Graphs

Saving Graphs

Graph With Save Button Called Out. Screenshot.

A Save button will appear when savable changes have been made to your graph. Click Save to save the graph to your account.

Pop Up Window To Name A Graph. Screenshot.

If you would like to Rename and Save your graph, click on the title next to the Save button.

As you make changes to the graph, the Save button will keep appearing. To save any updates or changes, you will need to keep saving.

Graph Menu Opened With Graph Selected And Open Graph Called Out. Screenshot.

Access all of your saved graphs by clicking on the three bars in the upper left corner of your graph.

To open any of your saved graphs, click on the graph’s name in this menu and select Open Graph.

Managing Your Saved Graph Collection

Graph Menu Opened With Search Feature Called Out. Screenshot.

Your saved graphs will appear in chronological order, starting with the most recently saved graph.

To Search through your saved graphs, click on the magnifying glass icon near your name at the top of the screen.

Graph Menu Opened With Delete Graph Called Out. Screenshot.

Delete any graphs you no longer wish to have in your account by clicking on the X next to the graph.

A message saying "Deleting..." will show up as well as a Cancel option. You have 5 seconds to undo your deletion by clicking the Cancel option.

Pop Up Window To Name A Graph With Duplicate Graph Selected. Screenshot.

Sometimes you may wish to work in a saved graph file but not change the original file.

To do this, click on the name of the graph and select Duplicate This Graph and then the Save button. This will create a new graph save file, separate from the original.

Sharing Your Saved Graphs

Share Menu Opened on Graph.  Screenshot.

To share a permalink for your graph, click the Share button in the top toolbar of the calculator.

A drop down menu will appear with a section titled "Share your graph" You can copy and paste this link to share your graph and all of your expressions. Click Copy to copy the link to your clipboard.

Export Your Graph Pop Up Window. Screenshot.

Options also exist in this drop down menu to Print your graph (frequently also used to save as a PDF by changing your printing destination), as well as Export your graph to an image file (PNG or SVG).

Embed Graph Share Screen With HTML Code. Screenshot.

This drop down menu also allows you to copy the HTML code necessary to Embed your graph in another web page.

Recovering Unsaved Graphs

Graph Menu Opened With Attempt Recovery Feature Called Out. Screenshot.

If you forgot to save a graph before navigating away from the calculator page, you may still be able to recover your work.

When you click the three bars in the top left of the calculator, you should see a link that says Attempt Recovery.

Graph Menu Opened With Recovered Work Called Out. Screenshot.

After clicking Attempt Recovery, you should see a list of your most recent unsaved work, titled as Recovered Work.

Help Menu With Email Our Support Team Called Out. Screenshot.

If Attempt Recovery doesn't recover your graph, email us at support@desmos.com and tell us a little bit about your graph so we can try to recover it for you. However, please note that if the graph was never saved, we may not be able to recover it.

Please describe the graph as best you can, let us know about when you last worked on it (including what time zone you're in) and what your Desmos account email is.

Was this article helpful?
3 out of 4 found this helpful